Supported Web Browsers

To get the best experience of XpertHR we recommend using one of our supported web browsers: Internet Explorer 8 and above and the latest versions of Chrome, Firefox and Safari.

If you use an unsupported browser you may experience problems in certain areas of the XpertHR site even if most pages appear to be working correctly. For this reason we will show you a message advising you to use a supported browser instead.

In some cases you might see our message advising you to upgrade your browser when you are in fact using a supported browser version. If this happens to you while using Internet Explorer, please change the following setting:

  • Select the Tools menu (you might need to press Alt on the keyboard to get the menu to display) and choose "Compatibility View Settings".
  • From the list of "Websites you've added to Compatibility View", highlight
  • Click "Remove".